Why can’t I access the secure pages of TheTollRoads.com? I get a message saying TLS error.

For security reasons, after August 22, 2016, secure portions of TheTollRoads.com no longer support outdated versions of internet browsers. In order to access secure areas* of our website, please update your browser:

  • Internet Explorer**
  • Chrome
  • Firefox

*Secure areas of TheTollRoads.com include the following pages: Pay Toll Now; account login, sign up and management; violation resolution; and contact us.

**If your version of Windows doesn’t support the latest version of Internet Explorer, please use Chrome or Firefox.

Topic: 
Most Popular FAQs
Back to Top

We’ve updated our Privacy Policy.

TCA is committed to protecting your privacy and keeping you informed. Click here to read our Privacy Policy and learn how your information is collected, used, stored, shared and protected.